MC4WP_Admin_Tools::get_required_capability ()

Get required capability to access settings page and view dashboard widgets.

Return: (string)

Source file: admin/class-admin-tools.php

View source



Source

    public function get_required_capability() {

        $capability = 'manage_options';

        /**
         * Filters the required user capability to access the settings pages & dashboard widgets.
         *
         * @ignore
         * @deprecated 3.0
         */
        $capability = apply_filters( 'mc4wp_settings_cap', $capability );

        /**
         * Filters the required user capability to access the MailChimp for WordPress' settings pages, view the dashboard widgets.
         *
         * Defaults to `manage_options`
         *
         * @since 3.0
         * @param string $capability
         * @see https://codex.wordpress.org/Roles_and_Capabilities
         */
        $capability = (string) apply_filters( 'mc4wp_admin_required_capability', $capability );

        return $capability;
    }


User Contributed Notes

You must log in before being able to contribute a note.